Unable to Connect to Power Pivot Model

Aug 11, 2015 at 3:16 PM
Hi guys

I have no issues connecting to SSAS cubes but unfortunately I can't connect to any Power Pivot model.

I am able to select PowerPivot Model as a Data Source using the Connection button but as soon as I click Connect I immediately receive the following error message: "Could not connect to the 'Power Pivot model': The connection either timed out or was lost".

I'm using Excel 2010, 64 bit.

Any suggestions? Is there a way to get a detailed error log?


Thanks,
Simon
Coordinator
Aug 11, 2015 at 10:44 PM
Hi Simon,

Do you by any chance happen to have SQL 2014 or the client tools for it installed on your machine?

If so the config file fix that I suggested for this issue should fix this issue. I have a fix in the install script so this issue will not be a problem with releases after 2.2.6

If that is not your problem there is a section at the bottom of the documentation page which outlines how to switch on logging:
Marked as answer by simonnuss on 8/12/2015 at 5:32 AM
Aug 12, 2015 at 12:32 PM
Yes, I have SQL 2014 installed.

Your solution worked great, thanks dgosbell!
Nov 17, 2016 at 8:34 PM
Hi,

I downloaded v2.5 today, never used the program before, but I'm very eager to get working on it. I am struggling with this very same issue.

I use Excel 2010 SP2 32bit

The program launches correctly, the PowerPivot datamodel is found, but when I hit 'connect' I get this very same error message.

Connecting with PowerBI works just fine. Given your comment above that this should be solved from v2.2.6 onwards, could it be that there is a different cause here? Also, when I look in the .config file, versions 11 and 12 are no longer there, both are 13 now.

Any suggestions? Happy to provide any additional information if that would be needed.

Thx in advance,
Juan
Coordinator
Nov 21, 2016 at 9:08 PM
Yes, the specific bug in this thread was fixed in v2.2.6, but we still very occassionally see issues around the install and detection of the dependencies.

In the folder where DAX Studio is installed you should find a small app called DaxStudio.Checker.exe. Can you run that and past the output back to this thread? It will just list out the versions of .Net, AMO and ADOMD that you have on your system and might give us some hints as to where to start looking to resolve this issue.