Not connectiong with the PowerPivot Model

Jan 6, 2014 at 6:33 PM
Excel 2010 - 32 bit
Powerpivot x86
Dax Studio 1.2 x86

Hi guys,

Thanks for your help in advanced.

I launched Dax Studio with the PowerPivot Window on and inside a Pivot Table (the only one in the file) and I still don't have the error notice.

How can I overcome the issue?

If you need the file can you tell me how / where to upload?

Cheers,

Rafael
Jan 7, 2014 at 1:46 PM
Edited Jan 7, 2014 at 1:54 PM
Hello,

I have the same issue. The dropdowns are empty when opening the DAX Studio AddIn. Additonally, I just created an empty excel sheet with a simple table, added this to the data model and then created a pivot table from within power pivot. Back in the excel view I clicked on the pivot table and started the AddIn resulting in; no error message but empty dropdowns.

I run excel 2013 64bit on Windows 7.

Any tipps? I tried uninstalling the addin. I tried it also on Excel 32bit with the 32bit version of the AddIn.

Best regards,
Damian
Coordinator
Jan 10, 2014 at 6:40 AM
At the moment, the only way we can detect the presence of a PowerPivot model is by scanning the connection strings of all the PivotTables in the active workbook. When you created the Pivot table did you have any data in it? You may need to drag in a single measure for the query string to be initialized. If that does not work can you create an issue and attach the problem workbook so that I can have a look at it?
Jan 28, 2014 at 8:54 PM
I have created na issue with na exemple as requested! Many thans in advance!
Sep 19, 2014 at 7:20 AM
Hi,

We have to follow the instructions in the link.

First we have to select the powerpivot table and launch the powerpivot

below link explains

http://paultebraak.wordpress.com/2012/07/09/introducing-dax-studio/
Dec 16, 2014 at 11:42 AM
I had the same problems and by enabling tracing I noticed the error "System.FormatException", which indicated a problem with regional settings.

I updated the Format (Control Panel, Region and Language) to English (United States). My Excel is configured to use system decimal and thousand separator.

After that the error was gone and DAX Studio correctly detected the PowerPivot model. I hope this is the case for you guys as well.

Stack trace bellow:

2014-12-16 14:09:18.940 +02:00 [Error] Exception: "System.FormatException: Input string was not in a correct format.
at System.Number.ParseSingle(String value, NumberStyles options, NumberFormatInfo numfmt)
at DaxStudio.ExcelHelper.HasPowerPivotData()
at DaxStudio.ExcelAddin.Xmla.WorkbookController.GetHasDatamodel()
Dec 16, 2014 at 11:50 AM
Edited Dec 16, 2014 at 11:54 AM
Screenshots:
Image

Image
Coordinator
Dec 16, 2014 at 10:01 PM
@hascheidl - thanks for that. I also had someone else send me some logs for this over the weekend and I've been able to find and fix this issue in the code. It will be in the next release after the current 2.0.0.15 release.