This project has moved. For the latest updates, please go here.

Could not connect to Power Pivot Model

Jun 16, 2016 at 3:33 PM
I'm trying to use Dax Editor, but when I try to connect to a Power Pivot workbook I get the message:
"Could not connect to "Power Pivot Model' etc"

I searched and find this page, ran the script and get:
"PSChildName Version

v2.0.50727 2.0.50727.4927
v3.0 3.0.30729.4926
Windows Communication Foundation 3.0.4506.4926
Windows Presentation Foundation 3.0.6920.4902
v3.5 3.5.30729.4926
Client 4.6.01584
Full 4.6.01584

Client 4.0.0.0

ADOMD: Microsoft.AnalysisServices.adomdclient, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080c
c91
AMO: Microsoft.AnalysisServices, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91"

What should I do?

Tks for the help.
Coordinator
Jun 16, 2016 at 8:46 PM
What is the "etc" bit of the error message?

What version of Excel and Dax Studio are you using?

Have you only recently downloaded DAX Studio or have you had it installed for some time?

I've extended the error checking script and wrapped it into a small .net app here http://daxstudio.codeplex.com/releases/view/618744 - can you run that and post the output here?
Jun 20, 2016 at 8:08 PM
The DaxStudioChecker returns the following:

Checking .Net Framework

v2.0.50727 -> 2.0.50727.4927
v2.0.50727\1046 -> 2.0.50727.4927
v3.0 -> 3.0.30729.4926
v3.0\Setup -> 3.0.30729.4926
v3.0\Setup\1046 -> 3.0.30729.8763
v3.0\Setup\Windows Communication Foundation -> 3.0.4506.4926
v3.0\Setup\Windows Presentation Foundation -> 3.0.6920.4902
v3.5 -> 3.5.30729.4926
v3.5\1046 -> 3.5.30729.4926
v4\Client -> 4.6.01584
v4\Client\1033 -> 4.6.01584
v4\Client\1046 -> 4.6.01584
v4\Full -> 4.6.01584
v4\Full\1033 -> 4.6.01584
v4\Full\1046 -> 4.6.01584
v4.0\Client -> 4.0.0.0

Checking AMO

PASS > Microsoft.AnalysisServices, Version=11.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
PASS > Microsoft.AnalysisServices, Version=12.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
FAIL > It was not possible to load the file or assembly 'Microsoft.AnalysisServices, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91' or one of its dependecies. The system was not able to find the especified file.

Checking ADOMD.NET

FAIL > Não foi possível carregar arquivo ou assembly 'Microsoft.AnalysisServices.adomdclient, Version=11.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91' ou uma de suas dependências. O sistema não pode encontrar o arquivo especificado.
PASS > Microsoft.AnalysisServices.AdomdClient, Version=12.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
FAIL > Não foi possível carregar arquivo ou assembly 'Microsoft.AnalysisServices.adomdclient, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91' ou uma de suas dependências. O sistema não pode encontrar o arquivo especificado.

Dax Studio Configuration

Path: "C:\Program Files\DAX Studio\DaxStudio.exe"
Processing DaxStudio.exe.config file...
Path: 'C:\Program Files\DAX Studio\DaxStudio.exe.config'
Bindings Found: 5
AMO : 11.0.0.0 <default>
ADOMD : 11.0.0.0 <default>
Jun 20, 2016 at 8:14 PM
I'm using Excel 2016 and DaxStudio 2.3.6.
Coordinator
Jun 20, 2016 at 11:36 PM
Hmm, for some reason the installer thought you had v11 of the AMO and ADOMD dependencies, but you only have AMO at v11. But you do have both dependencies for v12. The 2.3.6 installer is meant to detect the highest common version between these two assemblies. I'm not sure why it does not work occasionally.

The quick fix is copy the 2 .config files from here https://1drv.ms/u/s!AnSKp2UbblSY7wy8XTjpaNRg8Ire and overwrite the ones where DAX Studio is installed (which is usually in "c:\program files\Dax Studio")
Jun 21, 2016 at 3:24 AM
Edited Jun 21, 2016 at 12:18 PM
OK, I appreciate your support. I saved the files and now I'm able to connect to the database model! Now I need to learn how to use it properly :)